Microsoft Project Tutorials

What you should learn about Microsoft Project:

	Task
	How
	Relevant Tutorial
	Your checklist

	Open Microsoft Project, enter activities in the “GANNT” chart view, switch between view, and save a file
Becoming familiar with MS Project navigation menu
	File menu
View menu
	Tutorial 1
	

	Link activities together
	Link task button
	Tutorial 1
	

	Use MS project to estimate the duration of a project,
	Project>Project Information
	Tutorial 1
	

	Identify the critical path in the “Network View”
	View>Network diagram
	
	

	Highlight the critical path in a GANNT chart
	Format>GANNT Chart Wizard
	Tutorial 3
	

	Assign resources to activities
	Assign Resources Button
or
Tools>Assign Resources
	Tutorial 2
Tutorial 3
	

	Use MS Project scheduling engine to deal with resource availability constraints
	Tools>Level Resources
	Tutorial 2
Tutorial 3
	

	Create a Milestone
	Create an activity of length 0
	Tutorial 3
	

	Create a summary task
	Indent sub-activities
	Tutorial 3
	

	Prepare a tracking GANNT chart (optional)
	Tools>Tracking>Update Tasks
	Tutorial 3
	

	Print a GANNT chart 
	File>Print
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IOMSM3092 – Managing Projects
An exercise in using Microsoft Office Project Standard 2003: The Film Making Project
You are the Unit Manager at a film company that has been contracted to produce a promotional film for a local organisation for a fixed fee.  It will be shot on location in Liverpool and a number of copies will be produced for release to the company’s customers.  The tasks and resources involved in making the film are fairly complex and so you have decided to use MS Project to help you schedule the work and track activities and costs.
Film making falls into three main parts.  Pre-production is about getting everything ready.  Production includes filming and recording the sound.  Post-production covers editing the material into the final film, ready for approval and release.
The following table shows the tasks for making our film and their duration.  Using this table create the Task Network, showing the interdependencies between tasks.  Also use the durations (in days) to do the Critical Path Analysis that shows the Earliest Start and Latest Start for each task.  This work should answer two basic questions:  How long (in working days) will it take to make the film?  What are the Critical Path activities?
	No.
	Task
	Duration (days)
	Predecessor(s)

	1
	Start
	0
	

	2
	Agree outline
	5
	1

	3
	Write draft script
	5
	2

	4
	Engage actors
	10
	3

	5
	Complete script
	4
	4

	6
	Select locations
	10
	3

	7
	Assemble equipment
	8
	2

	8
	Engage film crew
	1
	2

	9
	Rehearse actors
	2
	5

	10
	Shoot film
	5
	6, 7, 8, 9

	11
	Record voice-overs
	2
	9

	12
	Edit film
	10
	10, 11

	13
	Produce soundtrack
	5
	10

	14
	Assemble final version
	3
	12, 13

	15
	Show approval screening
	1
	14

	16
	Produce release copies
	5
	15

	17
	Distribute film
	4
	16

	18
	Finish
	0
	17



If you have done this correctly, the number of working days to make the film is 54.  The Critical Path runs through activities 0, 1, 2, 3, 4, 5, 9, 10, 12, 14, 15, 16, 17 and 18.
You are now ready to put data in MS Project.  The application should open ready to start a new project.  Transfer the task and duration information into the Task Name and Duration columns respectively.  Save your work regularly!  In fact, you might want to save the file under a different name at each stage, so if you make a mistake you don’t have to go right back to the beginning.
We need to insert a Milestone.  The film maker’s clients want to know when the script is finished.  Insert a new line after the Complete Script task (press the Ins key and an empty row appears), and type in Script Complete.  Give this task a duration of 0 days.  MS Project treats this as a milestone.
We shall now create the first of three Summary Tasks.  Click on to Agree Outline.   Press the Ins (Insert) key, or use Insert/New Task on the taskbar at the top of the screen.  Into the new blank line type Pre-Production.  Now click on Agree Outline again.  Use Crtl (Control) and a left click to highlight the next seven tasks up to Engage Film Crew.  Press the Indent button (the little green right arrow on the taskbar at the top) and these eight highlighted tasks should all move in slightly and the Pre-Production task will turn into a black bar which spans the sub-tasks below it.
After Record Voice-overs, insert a milestone for Acting Completed.  Create a Summary Task called Production, which spans the four Task Names from Rehearse Actors to Acting Completed.  If the Production task is automatically indented, highlight it and click the Outdent button (the little green left arrow on the taskbar at the top). After Show Approval Screening, insert a milestone called Approved for Release.  Create a Summary Task called Post-Production covering the Task Names from Edit Film to Produce Release Copies.
At this stage all of your tasks will show as blue bars starting on the same day.  The next step is to connect them according to the interdependencies shown on your Task Network diagram.  Do not use the Predecessor task numbers in the table above as they are not the same as the corresponding Task Name numbers in MS Project because you have added the Summary Tasks and Milestones.
The simplest way to connect tasks is as follows.  Highlight the first Task Name.  Press and hold the Ctrl (Control) key.  Highlight the dependent Task Name.  Release the Ctrl key.  Click on the Link Tasks button (a small piece of chain link) at the top of the screen.  An arrow should now run from the first task to the second.  Repeat this process for all the connected tasks, carefully checking your links with the Task Network you drew.  Remember not to create links to Summary Tasks but only to Sub-Tasks.  To keep the whole Gantt chart in view select View/Zoom…/Entire project.

Go to line 1 with a Task Name of Start.  In the Start column enter the date as 05/03/09.  If you have entered all the information correctly, the Finish date will be Thu 19/05/09.
Click on Format/Gantt Chart Wizard.  Select Critical Path, Resources and Dates on the radio buttons and then Format It.  The Critical Path will show up in red and should be the same as the Critical Path on your task diagram.
Up to this point you have not considered resources, but in fact quite a large team is needed to complete this film making project.  The following table shows the various roles; which tasks they are assigned to, and what proportion of their time will be used when they are (e.g. someone assigned as 0.5 will be needed for 4 hours in an 8 hour day); their Standard Rate of pay per hour.

	Role
	Task assignments
	Standard rate

	Director
	Agree outline (1), Engage actors (0.5), Select locations (0.5), Engage film crew (0.5), Rehearse actors (1), Shoot film (1), Record voice-overs (1), Edit film (0.5), Produce soundtrack (0.5), Assemble final version (0.5), Show approval screening (1)
	£60

	Writer
	Agree outline (0.5), Write draft script (1), Complete script (1), Edit film (0.2), Produce soundtrack (0.2), Show approval screening (1)
	£40

	Lead actor
	Rehearse actors (1), Shoot film (1), Record voice-overs (1)
	£50

	Supporting actors (2)
	Rehearse actors (1), Shoot film (1), Record voice-overs (1)
	£30

	Cinematographer
	Shoot film (1)
	£40

	Sound engineer
	Shoot film (1), Record voice-overs (1), Produce soundtrack (1),
	£30

	Lighting technician
	Shoot film (1)
	£30

	Editor
	Edit film (1), Produce soundtrack (0.5), Assemble final version (1)
	£40

	Unit manager
	Engage actors (0.5), Select locations (0.5), Assemble equipment (0.5), Engage film crew (0.5), Shoot film (0.5), Record voice-overs (0.2), Show approval screening (0.5), Produce release copies (0.5), Distribute film (1)
	£30



You can now enter the resources needed for each task.  Click on View/Resource Sheet and fill the Resource Name and Std. Rate columns.  The Max Units default to 1, so insert 2 for the number of Supporting Actors.  Go back to View/Gantt Chart.  You can now assign resources to each task.  Highlight Agree Outline.  Click on the small button showing two people (Assign Resources) at the top.  This will open a small box which contains summary information about the resources.  Use the table above to see which resources to assign to Agree Outline and the units.  In this case you should highlight Director and insert 1 unit, and Writer and assign 0.5 of a unit.  When you close the box you will see the resource labels added to the task bar on the Gantt chart.  Do this for all the other tasks.  You may notice that the Duration of the tasks changes automatically.  If this happens, manually correct them – check the durations with your Task Network.  
When you have finished (and saved your work!), click on View, Resource Sheet again.  You will see that several of the resources are in red type.  This is because the schedule you have entered requires more resources than are available (e.g. the Director is expected to be in two places at once).  You are going to solve this problem by resource levelling, which will ensure that all work is done within standard working days and no-one is overloaded.  Click on Tools/Level Resources.  Lick on Level Now without adjusting any of the settings.  Click on View/Gantt chart.  You will see that the programme has moved the tasks so that there is no resource overloading but the Finish date has gone back to 26/05/07.  You will also notice that several of the tasks have been broken up into chunks so that they run in parallel and key resources can move between them.  
To get a detailed view of the status of any task click on Window/Split.  This opens a new section in the bottom half of the screen.  When you highlight a task, the panel shows information like the hours of work planned for each for the resources and the task’s predecessors.  
To look at the labour costs of the film project click on View/Table… and select Cost.  This will show you the predicted labour costs of all the tasks, with the Summary Tasks allowing you to answer a question like “What’s the labour cost of Pre-Production”.  To get an overall project view, click Project/Project Information/Statistics.  This should show that the total predicted labour cost is £43,616.
To keep the exercise simple, this plan is only recording the labour costs.  The real project would also need to cover things like equipment hire, purchase of materials and fees for the use of a recording studio – not to mention overheads like office rates and utility bills.
This is a feasible plan, so you can now create the Baseline, which you can monitor progress against.  Click Tools/Tracking/Save Baseline and click OK.  

You can now enter information about the progress of the tasks.  In practice you would be doing this in real time so would have a clearer idea of where the project is ahead and behind.  Let’s imagine that it is the 20th April (20/04/09) and you are preparing your weekly progress report.
Highlight Agree Outline.  Click Tools/Tracking/Update Tasks.  Fill in % Complete as 100%.  Actual duration is 6d.  Remaining duration should default to zero.  Fill in the task updates according to the following table.

	Task Name
	% Complete
	Actual days
	Remaining days
	(Planned days)

	Agree outline
	100%
	6
	0
	5

	Write draft script
	100%
	8
	0
	6

	Engage actors
	100%
	8
	0
	10

	Complete script
	100%
	3
	0
	4

	Select locations
	100%
	7
	0
	10

	Assemble equipment
	100%
	4
	0
	5

	Engage film crew
	100%
	6
	0
	5

	Rehearse actors
	100%
	2
	0
	1

	Shoot film
	50%
	4
	4
	5

	Record voice-overs
	40%
	1
	2
	2



Once you have filled all this information in, you should have a clear picture of where the project is up to.   To see a summary of this, click View/Reports/Overview…/Project Summary.  This will show all the main information about the project on one page.
The reports shows that the Baseline predicted the project would run from 05/03/09 and finish on 26/05/09.  There would be a team of nine resources (the 2 supporting actors count as one resource), and the overall labour cost would be £43,616.  The snap shot view you have just created should indicate that the finish date is now likely to be 02/06/09, and the labour cost is likely to amount to £48,800.  
You present the report to the film company chief executive, who is understandably worried at the situation.  She has just had a telephone call from the client company, who are insisting that the film is ready by 27/05/09.  Given the slippage up to this point it’s not just a question of saving a couple of days.  You’ll have to shave a least a week off the project to give yourself some contingency.  You have a discussion about possible options, and you are asked to look at these in detail.  Try these options and see which will meet that target and hit the deadline.  And also see what the total project labour cost will be.  You want a solution that meets the deadline but which is the least expensive because any extra labour cost has to be absorbed by your firm and so risks turning a profit into a loss.
Keep to the current Shoot Film schedule, but have two Editors, and cut the Edit Film task from 10 days to 6 days.
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When starting, MS project defaults to a new project

A start date and other properties can be entered

Project Project Properties

Entering the end date is optional

Views

Use the GANNT chart view

We’ll use the others later on

Enter the task description and their length

To enter precedence relationships:

Select two activities with the “Control” key down

Then click on the “Link” button

The task is automatically moved on the GANNT chart
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Using Microsoft Project

When all the activities have been entered and linked:

The end date of the project has been automatically computed

See “Project Information” in the project menu
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MS Project

•

Consider the project network for the 

construction of a house

–

You are a project manager and get paid for your 

fees only

–

Most work is subcontracted to suppliers
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Project Information

Activity Duration Cost Supplier Availability

1-2 (a)

Obtainfinancing

12 weeks £500

M. Durand

Always

1-2 (b)

Design house

12 weeks £2500

Architect

December,

then

March 

onwards

2-3

Foundation

8 £2000

Diggers Ltd

March

onwards

2-4

Order and 

receive materials

4 £4000

Internal

Always

4-5

Build

4 £500

Indesign Ltd

Always

4-6

Select paint

12 £50,000

Happy

Builders Ltd

April

onwards

5-6

Select carpet

4 £500

Indesign Ltd

Always

6-7

Finish work

4 £16,670

Happy

Builders Ltd

April

onwards
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Project Information

		Activity		Duration		Cost		Supplier		Availability

		1-2 (a)
Obtain financing		12 weeks		£500		M. Durand		Always

		1-2 (b)
Design house		12 weeks		£2500		Architect		December,
then March onwards

		2-3
Foundation		8		£2000		Diggers Ltd		March onwards

		2-4
Order and receive materials		4		£4000		Internal		Always

		4-5
Build		4		£500		Indesign  Ltd		Always

		4-6
Select paint		12		£50,000		Happy Builders Ltd		April onwards

		5-6
Select carpet		4		£500		Indesign  Ltd		Always


		6-7
Finish work		4		£16,670		Happy Builders Ltd		April onwards
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To Do (1/2)

•

Enter this information in MS project

•

Steps:

1. Enter 01/12/09 as project start date

2. Verify that week-ends are non-working 

days

•

Tools>Change Working Times

3. Enter the activity and durations

4. Enter the precedence relationships

•

Completion date:  09/08/2010
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Enter the activity and durations

Enter the precedence relationships

Completion date:  09/08/2010
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To Do (2/3)

•

Steps:

5. Assign resources

•

Select a task (e.g. design)

•

Click on assign resource button

•

Type in resource name

•

(Alternatively, enter resource in GANNT chart view)

6. Enter costs

•

Convert all costs to £/hours (40 hours per week) 

(Simplification…)

•

View>Resource Sheet

•

Enter standard rate

7. Check total budget (£76,670)

•

Project>Project Information>Statistics
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To Do (3/4)

•

Steps:

8. Enter resource availability

•

Select a task (e.g. design)

•

Click on resource information button

•

Enter dates of availability

•

Leave blank if resource is always available

•

Enter 01/12/2010 as end of date for the 

“onward” resources
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To Do (4/4)

•

Steps:

8. Reschedule project

•

Tools>Level Resources…

•

Select “Automatic”

•

You should get a completion date of: 

05/10/2010
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Tools>Level Resources…

Select “Automatic”

You should get a completion date of: 05/10/2010
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Microsoft Project (1/5)

•

Before using MS Project, you need a 

good project management system in 

place

–

Deliverables, tasks, costs, etc.

•

MS Project is a tool to:

–

Build complete project plans (tasks + 

resources)

•

Not just a graphical tool (scheduling engine)

–

Track Progress

–

Plan for and take corrective actions
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Before using MS Project, you need a good project management system in place

Deliverables, tasks, costs, etc.

MS Project is a tool to:

Build complete project plans (tasks + resources)

Not just a graphical tool (scheduling engine)

Track Progress

Plan for and take corrective actions





Michel Leseure

Managing

Projects



Using Microsoft Project

When starting, MS project defaults to a new project

A start date and other properties can be entered

Project Project Properties

Entering the end date is optional

Views

Use the GANNT chart view

We’ll use the others later on

Enter the task description and their length

To enter precedence relationships:

Select two activities with the “Control” key down

Then click on the “Link” button

The task is automatically moved on the GANNT chart
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Using Microsoft Project

•

When starting, MS project defaults to a new project

•

A start date and other properties can be entered

–

Project



Project Properties

–

Entering the end date is optional

•

Views

–

Use the GANNT chart view

–

We’ll use the others later on

•

Enter the task description and their length

•

To enter precedence relationships:

–

Select two activities with the “Control” key down

–

Then click on the “Link” button

–

The task is automatically moved on the GANNT chart


